Game Join Error
Incident Report for Roblox
Resolved
The issue has been resolved but maintenance starts soon.
Posted Nov 19, 2020 - 08:35 UTC
Identified
The issue have found what is causing the joining error and we are working to fix it.
Posted Nov 19, 2020 - 08:35 UTC
Investigating
We are currently investigating the issue. When some players join the game the player gets kicked for Error 505. We have had many reports of this issue and we hope it is fixed soon.
Posted Nov 19, 2020 - 08:30 UTC