Major Roblox Outage
Incident Report for Roblox
Resolved
The outage has now ended. Ubuntu 's servers are no back up and running after a major update for the server handler.
Posted Nov 20, 2020 - 10:06 UTC
Identified
The issue has been identified with Ubuntu. Roblox should be back online soon. We are waiting for ubuntu's approval, as they will need to moderate the roblox website for a scan. When ubuntu is back you will receive and update,
Posted Nov 20, 2020 - 04:59 UTC
Investigating
The roblox server holder is currently having a major outage causing nothing on roblox to work, such as studio, joining games & opening the app on your device.
Posted Nov 20, 2020 - 04:50 UTC
This incident affected: Roblox Status (Website, Mobile App, Xbox App) and Creator (Website, Games, Studio, Asset Delivery, Data Store, Game Join).