Website Outage
Incident Report for Roblox
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 00:06 UTC
Identified
Due to maintenance, the roblox site will be shut down untill maintenance is complete.
Posted Jan 04, 2021 - 11:13 UTC
This incident affected: Roblox Status (Website).